[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas

Aller en bas

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Empty [WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas

Message par Bouz Ven 31 Déc 2021 - 14:56

Et voici le WIP qui m'occupe des derniers jours. J'en suis un poil plus loin que ce que je raconte ici (depuis hier soir, il boote, sans son), mais c'est long de raconter tout ça!
J'ai remporté une enchère pour un slot MV1-FT. J'avais un slot de cette taille HS bouffé par la rouille et je lui cherchais un remplaçant. L'objet vendu était vendu comme HS, avec une erreur Z80. Comment résister?

La vidéo de quand tout est réparé, une semaine plus tard:

Ce modèle a quelques avantages plutôt cool:
- Une ROM système DIP non soudée
- Une sortie stéréo amplifiée
- Une sortie casque stéréo non amplifiée (pour brancher les haut-parleurs amplifiés de ma borne) avec volume réglable séparément
- Deux prises DB15 pour brancher des joysticks directement sur le slot
- Des prises pour brancher les contrôleurs Mahjong (!).

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 001_le10

Au passage, j'imagine que vous connaissez les dénominations mieux que moi, mais MV1-FT, c'est un slot à 1 cartouche, avec des puces SNK produites par Fujitsu sur une base Toshiba.

Quand on branche la chose, on s'attend à obtenir une belle erreur Z80. Et on obtient...
Des flashs réguliers colorés à tendance vert-bleu.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 002_le10

J'enlève le support plastique pour faire une première inspection. Je m'attends à de la corosion dans la zone de la pile de sauvegarde, mais rien ne me saute aux yeux.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 003_pa10

On voit quand même une pile qui a été remplacée des boursoufflures bizarres.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 004_pi10

Sous la pile, c'est franchement crade. On dirait des restes de la colle des mousses de protection collées sous le PCB pour protéger certaines zones.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 005_le10

Je commence par enlever la pile pour mieux voir dessous, et pour éviter de créer des court circuits en bricolant sur les pistes de la plaque.
J'utilise la super pompe japonaise que j'ai reçue pour Noël.
Rien à signaler au niveau de la pile, à part des résidus de colle. Je fais du nettoyage.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 006_on10

Dans le voisinage de la pile, je trouve une SRAM qui a visiblement été remplacée. Et le réparateur n'avait visiblement pas de flux sous la main, parce que les soudures sont bien moches.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 007_un10

Le faut que l'écran flashe me fait penser à un souci avec le circuit de watchdog. Il est géré par le Neo-B1 (qui gère aussi le circuit de RESET, au démarrage de la machine, avec le transistor chelou en-dessous, qui n'en est pas un). Le B1 reçoit des commandes de la part du CPU à intervalles réguliers. S'il ne reçoit rien, il considère que le jeu est planté et il le redémarre.
Les flashs montreraient des reset en boucle, donc potentiellement un souci avec le CPU, la WRAM ou la ROM système (le BIOS).

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 008_pr10

J'élimine tout de suite la cause du mauvais contact sur la ROM système en l'enlevant et en la remettant en place pour gratter un peu les contacts.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 009_on10

Et... ça ne marche toujours pas!

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 010_ma10


Dernière édition par Bouz le Sam 8 Jan 2022 - 17:14, édité 1 fois
Bouz
Bouz
Scellé
Scellé

Messages : 2106
Date d'inscription : 11/06/2019
Age : 43
Localisation : Saint Bauzille de Putois

https://www.youtube.com/user/openio

Revenir en haut Aller en bas

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Empty Re: [WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas

Message par theWave Ven 31 Déc 2021 - 16:37

Le réf du slot c'est "MVF1T" d'après la photo c'est ça ?
ça correspond à un MV1T du tableau ici même ??

https://www.neogeo-players.com/t2108-les-differents-slots-mvs-neo-geo

_________________
Sanjuro a écrit:en Special Guest Star, WRC dans le rôle de theWave
ancien directeur du service de renseignements NGS, il a le bras long comme un anaconda sous stéroïdes, si un gros bonnet doit se coucher, c'est qu'il en a donné l'ordre.
theWave
theWave
Pièce unique
Pièce unique

Messages : 9155
Date d'inscription : 25/10/2015

Revenir en haut Aller en bas

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Empty Re: [WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas

Message par Bouz Ven 31 Déc 2021 - 17:14

@theWave a écrit:Le réf du slot c'est "MVF1T" d'après la photo c'est ça ?
ça correspond à un MV1T du tableau ici même ??

https://www.neogeo-players.com/t2108-les-differents-slots-mvs-neo-geo

Je pense qu'il s'agit d'encore un autre modèle.
Voilà la référence inscrite:

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 20211212

Il se rapproche plus du MV-1F dans ses specs, si on regarde ton tableau:
Switch mono/stéréo, donc Stéréo via harness (je pense qu'il y a une couille dans le tableau, parce que le switch sert à configurer le spin "Speaker -" du harness comme une voix ou comme la masse, si je ne m'abuse), stéréo via connecteur, connecteur casque et contrôle du volume casque.
Bouz
Bouz
Scellé
Scellé

Messages : 2106
Date d'inscription : 11/06/2019
Age : 43
Localisation : Saint Bauzille de Putois

https://www.youtube.com/user/openio

Revenir en haut Aller en bas

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Empty Re: [WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas

Message par snkspirit Ven 31 Déc 2021 - 17:32

Tu vas pouvoir nous montrer dans une vidéo explicative toute ta dextérité avec ton tout nouveau matos!

_________________
Y'a pas de pierre dure, que des bras mous !!!
[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 1568904079-latest
snkspirit
snkspirit
Pièce unique
Pièce unique

Messages : 7806
Date d'inscription : 28/06/2017
Age : 43
Localisation : Attention d'Angers (49)

Revenir en haut Aller en bas

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Empty Re: [WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas

Message par Bouz Ven 31 Déc 2021 - 18:46

Avec plaisir, dès que j'aurai trouvé ce qui cloche.
La suite du roman photo probablement ce soir pendant le film pour enfants... Wink
Bouz
Bouz
Scellé
Scellé

Messages : 2106
Date d'inscription : 11/06/2019
Age : 43
Localisation : Saint Bauzille de Putois

https://www.youtube.com/user/openio

Revenir en haut Aller en bas

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Empty Re: [WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas

Message par Bouz Sam 1 Jan 2022 - 9:27

Je vérifie l'état du pin de reset du 68000 pour voir s'il est effectivement redémarré en boucle...

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 011_le10

Et c'est le calme plat. Pas de reset en vue, et pourtant, l'écran continue à flasher!

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 012_il10

Par contre, j'ai bizarrement un message lisible qui apparait, en plus des merdouilles vertes. Il y a donc un peu de vie qui sort de cette machine, mais ça se bouscule sur les accès mémoire.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 013_un10

Je fais le tour des broches des bus d'adresses et de données du 68000 pour voir si je trouve des choses bizarres.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 014_vz10

Et je trouve 10 broches bloquées à l'état 0. Il y a vraiment quelque chose qui cafouille sur le bus.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 015_qu10

J'échange la ROM système par le Neo Diagnostics, histoire de voir si je peux avoir des détails. Si le CPU a un bus moisi, ça ne devrait pas apporter grand chose, mais au moins, quand ça marchera, je serai le premier au courant!

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 016_di10

Oui, voilà, donc c'est pas beau.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 017_pa10

La SRAM toute mal soudée est une bonne candidate à la catastrophe. Je vérifie l'état des soudures avec mon aiguille, et je retrouve 5 pads arrachés!

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 018_5_10

Parmi ces pads, on retrouve celui de la broche /OE, qui correspond à l'activation de la sortie de la RAM sur le bus. Typiquement le truc qui pourrirait tout le trafic.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 019_le11

On observe 2 jeux de 2 puces de RAM de 32k x 8bits, pour former des mots de 16 bits. Les 4 puces partagent le bus d'adresse. Le bus de données de 16 bits est partagé entre les puces de gauche et celles de droite. On devrait donc avoir 2 puces de WRAM (probablement celles du bas, plus proches du CPU) et 2 puces de BACKUP RAM (celles du haut, plus proches de la pile de backup.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 020_2_10

Ca se vérifie facilement, en regardant comment les puces sont alimentées. Les 2 du bas sont alimentées par le rail de +5V, tandis que les 2 du haut sont alimentées par le transistor proche de la pile de sauvegarde.
On a donc une puce de BACKUP RAM dans la tourmente. La tentation est forte de carrément la dégager pour qu'elle libère le bus et me fasse passer le test du Neo Diagnostics BIOS. Mais vu l'état des pads, enlever la SRAM risquerait d'arracher des pistes et de compliquer la réparation.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 021_id10

En tripotant les pistes, j'arrive à voir quelques messages tout sales qui sortent à l'écran.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 022_en10

Pour m'assurer que les pads défectueux ne sont pas rattachés à des pistes coupées, je vérifie la continuité des pistes entre les broches des puces qui se partagent les bus. Pas de pistes coupées. C'est moche et boîteux, mais ça a l'air de marcher.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 023_vz10

Le rafraîchis les soudures avec du flux, de l'étain, et une pointe de fer plate. Après ça, c'est tout beau.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 024_rz10

Et.. miracle, j'obtiens l'écran que je voulais voir sans oser l'attendre.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 025_et10

Et comme je suis comme un fou, je remonte le support de cartouche, et j'insère la carte de diagnostics de la section Z80.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 026_je10

Et là, je m'aperçois que les problèmes sont de retour. C'est moins horrible qu'avant, mais c'est tout cassé. Le fait d'avoir mis le support en plastique aurait cassé quelque chose? En tout cas, je n'ai entendu aucun son pendant le diagnostic. Il doit y avoir EN PLUS un problème sur la section Z80 (sinon, on entend des bips aux démarrage).

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 027_et10

Je fais des tests en essayant de plier la carte dans tous les sens. Je vois que si j'appuie un peu de partout, ça influe sur l'état de l'affichage!
Par exemple, si j'appuie là...

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 028_si10

Ca me fait un truc qui marchouille. Et sur un coup de bol, j'arrive même à avoir le bon affichage.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 029_ca10

Après plus d'une heure à tourner en rond, je finis par localiser le problème autour du LSPC2, le processeur graphique de la machine. Il pilote les lignes de bus de la VRAM, justement.
Quand j'appuie sur les broches par ici, j'arrive à rétablir l'affichage.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 030_je10

Un coup de microscope et d'aiguille, et je vois un gros tas de crasse et des broches qui se décollent! (j'y suis allé un peu fort, là, j'ai été surp)

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 031_vu10

Un coup de flux, un peu trop d'étain, et je refais les soudures.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 032_je10

Maintenant, je peux appuyer de partout comme un âne.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 033_on11

Et ça marche à tous les coups!

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 034_el10

Par contre, je n'ai pas de son!
Bouz
Bouz
Scellé
Scellé

Messages : 2106
Date d'inscription : 11/06/2019
Age : 43
Localisation : Saint Bauzille de Putois

https://www.youtube.com/user/openio

Revenir en haut Aller en bas

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Empty Re: [WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas

Message par snkspirit Sam 1 Jan 2022 - 9:51

Pour l'instant je capte study (en fin a peut près) mrgreen

_________________
Y'a pas de pierre dure, que des bras mous !!!
[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 1568904079-latest
snkspirit
snkspirit
Pièce unique
Pièce unique

Messages : 7806
Date d'inscription : 28/06/2017
Age : 43
Localisation : Attention d'Angers (49)

Revenir en haut Aller en bas

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Empty Re: [WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas

Message par Bouz Sam 1 Jan 2022 - 18:39

Et comme on veut quand même voir un truc un peu plus joyeux et plus concret, on rebascule sur l'Unibios et on insère notre cartouche de test préférée.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 035_un10

Et on a bien un slot qui marche! Enfin au son près!

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 036_pb10

Si on réactive les tests au démarrage dans l'Unibios (ils sont désactivés par défaut)...

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 037_ac10

On se retrouve avec cette bonne vieille erreur Z80.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 038_er10

On rebascule tout ça en mode diagnostic, avec le BIOS de diagnostics et la ROM SM1 dans le port cartouche.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 039_av10

Et on reçoit le message qui indique que le slot ne communique pas avec la carte. Autrement dit, on ne sait pas ce qui se passe.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 040_z810

Je m'attaque sur la broche de la ROM SM1 qui indique qu'elle est accédée par le slot.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 041_la10

Et... eh ben la ROM reste inactive.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 042_ch10

Sur le coup, j'ai retracé toute la logique de bascule entre la ROM M1 et la ROM SM1. Ca m'a pris la journée de samedi en entier.
La bonne nouvelle, c'est que j'ai compris.
La mauvaise, c'est que le problème ne venait pas de là.
En fait, la communication dans la section Z80 est tellement pétée qu'elle ne passe pas la limite du slot.
Pour vérifier ça, je regarde les différentes lignes des bus d'adresses et de données à l'oscilloscope. Les lignes relient le Z80, la SRAM, l'EPROM M1, l'EPROM SM1 et le SPU Yamaha. Je sonde la ROM M1 parce que c'est plus pratique!

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 043_so10

Voilà ce qu'on trouve quand le signal est correct. Des fronts bien clairs avec des niveaux haut et bas bien marqués. Ici, on a la ligne de données Q6.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 044_la10

Et voilà ce que ça donne sur la ligne Q7...

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 045_la10

Et voilà, on a une ligne morte. Elle est tuée par l'un des composants ciyés plus haut.
L'ancien propriétaire m'a dit qu'il avait changé le Z80. Je me rabats donc sur le candidat le plus probable parce que le plus fragile, la SRAM.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 046_on10

Je dessoude la SRAM en ajoutant d'abord de l'étain sur toutes les broches, puis je les dessoude avec ma super pompe toute neuve, et puis je finis au pistolet à air chaud parce que je misère à bloc.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 047_de10

Et je vais coller un beau support à la place.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 048_le10

Je vais tester la SRAM hors circuit avec mon MiniPro qui sert à tout...

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 049_te10

Et le testeur me dit clairement qu'elle est morte!

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 050_el10

Ca tombe bien, j'en ai un stock pour réparer autre chose.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 051_le10

Je soude le support parce que ça, au moins, c'est facile.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 052_so10

Histoire d'être sûr que le boîtier sait bien vérifier une SRAM, je vais tester la nouvelle.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 053_te10

Et hop, elle la reconnait bien, on a donc quelques chances qu'elle change la donne une fois sur le slot.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 054_te10

Je mets donc la SRAM en place. Et j'en bave un peu avec l'écartement parce que je suis super habile de mes doigts. Bref, ça finit par rentrer.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 055_re10

Je remonte la carte de test, je démarre fébrilement, et... ça ne s'entend pas sur la photo, mais on entend bien les bips de la ROM de diagnostic. Ca sent bon!

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 056_le10

Je bascule maintenant l'affichage pour voir si tout va bien. Et ALL TESTS PASSED!

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 057_al10

Ca sent bon, alors je remonte le slot. Au passage, je lui ajoute des pieds, parce qu'il était vendu sans. Je lui remets son accu, parce qu'il était en bon état, tenait la charge, et n'était pas une de ces bouses en NiCd qui coule de partout.
Je lui colle un Unibios, une cartouche...

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 058_re10

Et je lance le test final. Et tout fonctionne. Le jeu et le son fonctionnent à merveille.
Voilà un bon gros slot qui fonctionne.

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas 059_te10
Bouz
Bouz
Scellé
Scellé

Messages : 2106
Date d'inscription : 11/06/2019
Age : 43
Localisation : Saint Bauzille de Putois

https://www.youtube.com/user/openio

Revenir en haut Aller en bas

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Empty Re: [WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas

Message par juicelink Sam 1 Jan 2022 - 18:44

Bravo Bouz !
le réanimator de MVS !

_________________
http://www.flashkof.fr
[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Sign_a10[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Sign_m10[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Sign_p10[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Sign_l11
juicelink
juicelink
Mintissime !
Mintissime !

Messages : 1583
Date d'inscription : 07/11/2015
Age : 44
Localisation : Caluire et Cuire

http://www.flashkof.fr

Revenir en haut Aller en bas

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Empty Re: [WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas

Message par Bouz Sam 1 Jan 2022 - 19:43

@juicelink a écrit:Bravo Bouz !
le réanimator de MVS !
Merci! Plus que 5 à réparer, et j'arrête Smile
Bouz
Bouz
Scellé
Scellé

Messages : 2106
Date d'inscription : 11/06/2019
Age : 43
Localisation : Saint Bauzille de Putois

https://www.youtube.com/user/openio

Revenir en haut Aller en bas

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Empty Re: [WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas

Message par anzymus Sam 1 Jan 2022 - 21:27

J'ai rien pigé.

Bravo, t'es un petit magicien.

_________________
[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Signature
anzymus
anzymus
Scellé
Scellé

Messages : 4155
Date d'inscription : 25/10/2015
Age : 39

https://www.neogeo-players.com

Revenir en haut Aller en bas

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Empty Re: [WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas

Message par Bouz Dim 2 Jan 2022 - 0:12

@anzymus a écrit:J'ai rien pigé.

Bravo, t'es un petit magicien.

Je vais essayer de mieux expliquer à l'oral. Il va falloir que je fasse quelques incrustations, ça va prendre un petit moment avec mon matos tout naze Wink.
Bouz
Bouz
Scellé
Scellé

Messages : 2106
Date d'inscription : 11/06/2019
Age : 43
Localisation : Saint Bauzille de Putois

https://www.youtube.com/user/openio

Revenir en haut Aller en bas

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Empty Re: [WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas

Message par shadowfox Dim 2 Jan 2022 - 11:50

Oui, mais ça s'entend pas sur la photo, je suis déception. mrgreen

_________________
Ma chaine YouTube : Arcade Zap
[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Sign_c10[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Sign_l11    [WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Arcade10
shadowfox
shadowfox
Scellé
Scellé

Messages : 2841
Date d'inscription : 03/03/2016
Age : 33
Localisation : DTC

https://www.youtube.com/channel/UCeLMrbfrQ2ybTej6728Eafw

Revenir en haut Aller en bas

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Empty Re: [WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas

Message par anzymus Dim 2 Jan 2022 - 13:47

En fait j'ai pas les bases donc je sais même pas quel est le chemin logique que tu suis.

_________________
[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Signature
anzymus
anzymus
Scellé
Scellé

Messages : 4155
Date d'inscription : 25/10/2015
Age : 39

https://www.neogeo-players.com

Revenir en haut Aller en bas

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Empty Re: [WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas

Message par Bouz Sam 8 Jan 2022 - 17:12

@anzymus a écrit:En fait j'ai pas les bases donc je sais même pas quel est le chemin logique que tu suis.

J'espère que tu comprendras mieux avec ça Wink:



J'aurais dû être infographiste.
Bouz
Bouz
Scellé
Scellé

Messages : 2106
Date d'inscription : 11/06/2019
Age : 43
Localisation : Saint Bauzille de Putois

https://www.youtube.com/user/openio

Revenir en haut Aller en bas

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Empty Re: [WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas

Message par bladerunner Sam 8 Jan 2022 - 18:25

Chapeau beau travail ! yesss
Tu t'y connais quand je vois les phases de test que tu fais, j'en suis incapable. Je suis juste bon dans les soudures.

Est-ce que tu as constaté lors de tes réparations de slot que c'étaient souvent les mêmes composants qui posaient problème ou pas ?


A 11.16 Laughing
Je commence a bien souder le support en prenant soin de bien cacher le boulot avec mon bras.

_________________
FLICKR
bladerunner
bladerunner
Scellé
Scellé

Messages : 2197
Date d'inscription : 04/02/2017
Age : 42

Revenir en haut Aller en bas

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Empty Re: [WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas

Message par Bouz Sam 8 Jan 2022 - 18:34

Merci Wink.
Le MVS, c'est un peu spécial, parce que les ROMs de test aident carrément aux diagnostics. Pour le reste des PCB, c'est plus vaste.
MAis la base reste la même: vérifier que l'oscillateur sort quelque chose, vérifier que le CPU n'est pas bloqué en mode RESET ou en mode watchdog, vérifier l'activité des lignes de bus. Toujours le même cérémonial me concernant, et on trouve souvent un point de départ pour le reste de l'analyse.
Sur les MVS, pour le moment, j'ai eu pas mal de Z80 HS, il y a probablement un problème de conception de la synchro du bus sur la section audio. Normalement, ce n'est pas censé être un composant particulièrement fragile. Après, les RAM vieillissent mal et sont sensibles à la chaleur.
Et puis le cas classique des soudures cassées pour tout ce qui a des cartouches et se prend des déformations du PCB (comme j'ai fait de manière exagérée pour provoquer le problème ici). Je suis tombé sur le même problème sur une grosse puce d'un Sega STV, d'ailleurs.
Bon, mais ça, ce n'est que la vue de mon petit périmètre. Quand je lis le blog rep-arcade, je me dis que j'ai de la chance de ne pas tomber sur des custom chips HS!
Bouz
Bouz
Scellé
Scellé

Messages : 2106
Date d'inscription : 11/06/2019
Age : 43
Localisation : Saint Bauzille de Putois

https://www.youtube.com/user/openio

Revenir en haut Aller en bas

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Empty Re: [WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas

Message par bladerunner Sam 8 Jan 2022 - 19:29

C'est vraie que pour le slot le fait de pouvoir utiliser une carte test ça apporte une base mais ça reste quand même du matériel solide le slot mvs j'ai l'impression, quand tu vois comment ça a été utiliser dans le temps.

Prochainement je vais prendre un supergun pour quelques pcb, je croise les doigts pour ne pas avoir de problèmes électroniques enfin pour l'instant pas de souci.

Oui rep-arcade c'est impressionant aussi son travail et j'ai vu que tu utilisais du flux en gel, c'est plus pratique pour toi que le liquide ?

_________________
FLICKR
bladerunner
bladerunner
Scellé
Scellé

Messages : 2197
Date d'inscription : 04/02/2017
Age : 42

Revenir en haut Aller en bas

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Empty Re: [WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas

Message par Bouz Sam 8 Jan 2022 - 20:23

Le flux liquide, je n'en utilise pas. Dans tout étain au plomb qui se respecte, il y a une âme de flux au centre de la gaine en étain. Et en général, il y en a assez.
S'il y en a besoin pour de la soudure de composants traversants, c'est parce que le PCB est contaminé. Je me contente de nettoyer les plaques à trous à l'alcool isopropylique avant de souder des composants dessus, puis ça marche impec.
Le flux en gel, c'est du Chipquik. Il est particulièrement intéressant pour les soudures CMS. Là, par contre, il faut du flux pour que l'étain passe entre le circuit et les pattes des composants. Et le gel est tout à fait approprié pour ça, parce qu'il reste près de la zone à souder.

Bref, je ne suis pas du genre à asperger mes plaques de flux liquide. D'autant qu'il faut parfois le nettoyer sous peine qu'il devienne conducteur (notion de clean/noclean flux).
Bouz
Bouz
Scellé
Scellé

Messages : 2106
Date d'inscription : 11/06/2019
Age : 43
Localisation : Saint Bauzille de Putois

https://www.youtube.com/user/openio

Revenir en haut Aller en bas

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Empty Re: [WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas

Message par bladerunner Sam 8 Jan 2022 - 21:26

J'utilise du flux en pâte parce que le fil que j'utilise n'est pas de très bonne qualité, je galère parfois ou alors c'est mon fer qui est trop chaud.

_________________
FLICKR
bladerunner
bladerunner
Scellé
Scellé

Messages : 2197
Date d'inscription : 04/02/2017
Age : 42

Revenir en haut Aller en bas

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Empty Re: [WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas

Message par Bouz Sam 8 Jan 2022 - 21:30

Pour la température, je suis en permanence sur 300 degrés.
Je passe à 350 pour les plans de masse, mais c'est tout.
300, ça me suffit et ça évite de tout brûler.
Bouz
Bouz
Scellé
Scellé

Messages : 2106
Date d'inscription : 11/06/2019
Age : 43
Localisation : Saint Bauzille de Putois

https://www.youtube.com/user/openio

Revenir en haut Aller en bas

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Empty Re: [WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas

Message par Bouz Ven 14 Jan 2022 - 19:54

@anzymus a écrit:En fait j'ai pas les bases donc je sais même pas quel est le chemin logique que tu suis.

Ca va mieux à l'oral? Smile
Bouz
Bouz
Scellé
Scellé

Messages : 2106
Date d'inscription : 11/06/2019
Age : 43
Localisation : Saint Bauzille de Putois

https://www.youtube.com/user/openio

Revenir en haut Aller en bas

[WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas Empty Re: [WIP 100%] Réparation d'un slot MV1-FT qui ne démarre pas

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum