Le Deal du moment :
Cartes Pokémon EV6.5 : où trouver le ...
Voir le deal

[Wip] réparation slot mv1Achx #6

Aller en bas

[Wip] réparation slot mv1Achx #6 Empty [Wip] réparation slot mv1Achx #6

Message par Ragefan Mar 12 Sep 2023 - 22:15

Hello,
Dans l'attente de quelques puces de rechange, je déterre un vieux MVS série 1ACHX victime d'un click of death.
Il redémarre en boucle sous le Watchdog.

Tous les bus de donnees du 68k sont à haut et tous les buts d'adresse bagottent. (Est ce normal ?)

La work ram 2 ne passe jamais en écriture alors que la 1 oui.
Après changement, le comportement est le même.

Je regarde le neo-mga et ses pins WWU et WWL. Ils sont bien liés aux ram 1 et 2 mais en sortie du neo-mga, WWL reste toujours haut.

J'en déduis simplement que le neo-mga est potentiellement HS ? Pourrais t il y avoir une autre cause ?


Merci !
Ragefan
Ragefan
Loose
Loose

Messages : 135
Date d'inscription : 03/09/2023

Revenir en haut Aller en bas

[Wip] réparation slot mv1Achx #6 Empty Re: [Wip] réparation slot mv1Achx #6

Message par Ragefan Mar 12 Sep 2023 - 23:36

WWL reste toujours haut ou ne vas pas assez bas pour trigger le signal actif. Comme je n'ai pas d'oscillo...
Ragefan
Ragefan
Loose
Loose

Messages : 135
Date d'inscription : 03/09/2023

Revenir en haut Aller en bas

[Wip] réparation slot mv1Achx #6 Empty Re: [Wip] réparation slot mv1Achx #6

Message par Bouz Mer 13 Sep 2023 - 3:54

Je ne maîtrise pas l'architecture eu MV1A, c'est un monde à part!
Il n'y a pas d'intermédiaire entre le Neo-MGA et les puces de RAM?
Dommage en effet de ne pas avoir d'oscillo. Je connais une offre intéressante... Wink.
Si c'est un souci d'écriture en WRAM, et pas de lecture, alors la section de WRAM concernée devrait pouvoir s'activer (sortie de l'état haute impédance) correctement. Le slot devraot donc pouvoir fonctionner (les bus adresses et données entre le CPU et la ROM fonctionner). Du coup, la ROM de diag devrait marcher!
Bouz
Bouz
Scellé
Scellé

Messages : 3047
Date d'inscription : 11/06/2019
Age : 46
Localisation : Saint Bauzille de Putois

https://www.youtube.com/@AurelienBricole

Revenir en haut Aller en bas

[Wip] réparation slot mv1Achx #6 Empty Re: [Wip] réparation slot mv1Achx #6

Message par Ragefan Mer 13 Sep 2023 - 7:55

Merci Bouz, je vais revérifier avec le diag des que possible.
En fait , j'ai du mal à comprendre la logique minimale pour que la carte démarre sans click of death.
Je comprends qu'il faut un minimum de signal ok sur le 68k, il faut que le bus de donnée transfert des données (état haut ou qui bagotte ?), que le lien rom/68k/wram sur le bus de donnée et d'adresse ne soit pas coupé et que les mémoires soient actives en lecture uniquement ? Est ce bien l'état minimum qui devrait éviter le click of death ?

Je trouve bizarre dans mon cas qu'une ram passe en écriture et pas l'autre.




Ragefan
Ragefan
Loose
Loose

Messages : 135
Date d'inscription : 03/09/2023

Revenir en haut Aller en bas

[Wip] réparation slot mv1Achx #6 Empty Re: [Wip] réparation slot mv1Achx #6

Message par Ragefan Dim 17 Sep 2023 - 10:59

Bouz a écrit:Je ne  maîtrise pas l'architecture eu MV1A, c'est un monde à part!
Il n'y a pas d'intermédiaire entre le Neo-MGA et les puces de RAM?
Dommage en effet de ne pas avoir d'oscillo. Je connais une offre intéressante... Wink.
Si c'est un souci d'écriture en WRAM, et pas de lecture, alors la section de WRAM concernée devrait pouvoir s'activer (sortie de l'état haute impédance) correctement. Le slot devraot donc pouvoir fonctionner (les bus adresses et données entre le CPU et la ROM fonctionner). Du coup, la ROM de diag devrait marcher!

Le lien est bien direct entre le WWL et la ram 2 WE qui reste tjs haut continu même pendant les reboots, alors que le WE de la ram 1 passe de l'état haut à l'état 0 ( et non bas) lors des reboot. ( en gros,  le HI de la sonde clignote mais pas de LO)

Le OE bagotte bien sûr les 2 ram HI/LO

Je te confirme que la ram de diag ne fonctionne pas.

On pourrait imaginer le MGA est perturbé et ses signaux tirés vers le haut ?
Ragefan
Ragefan
Loose
Loose

Messages : 135
Date d'inscription : 03/09/2023

Revenir en haut Aller en bas

[Wip] réparation slot mv1Achx #6 Empty Re: [Wip] réparation slot mv1Achx #6

Message par Bouz Dim 17 Sep 2023 - 16:43

Je ne sais pas comment marche une sonde logique. On est censé avoir le hi et le lo qui clignotent, sinon le signal est flottant?
Tu peux tenter de mettre une resistance de 10kOhms entre le signal et la masse au cas où xe soit juste le pulldown du MGA qui est mort.
Sinon, pnus radical, tu coupes la liste et tu relies les /WE des deux puces de RAM Smile.
Bouz
Bouz
Scellé
Scellé

Messages : 3047
Date d'inscription : 11/06/2019
Age : 46
Localisation : Saint Bauzille de Putois

https://www.youtube.com/@AurelienBricole

Revenir en haut Aller en bas

[Wip] réparation slot mv1Achx #6 Empty Re: [Wip] réparation slot mv1Achx #6

Message par Ragefan Dim 17 Sep 2023 - 19:52

Je viens de changer les ram 1 et 2 et en fait, après avoir refait quelques mesures, le CS des rams 1 et 2 n'est pas actif Sad
Ça peut expliquer pourquoi le bios de diag ne démarre pas.

Sais tu quel est le signal qui debloque les rams ?
Ragefan
Ragefan
Loose
Loose

Messages : 135
Date d'inscription : 03/09/2023

Revenir en haut Aller en bas

[Wip] réparation slot mv1Achx #6 Empty Re: [Wip] réparation slot mv1Achx #6

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum