-16%
Le deal à ne pas rater :
Aspirateur balai Dyson V15 Detect Absolute (2023)
669 € 799 €
Voir le deal

[WIP] réparation MVS1 FZS #1

Aller en bas

[WIP] réparation MVS1 FZS #1 Empty [WIP] réparation MVS1 FZS #1

Message par Ragefan Dim 3 Sep 2023 - 22:34

Bonsoir à tous,

Je me lance dans la réparation de slot MVS avec plus au moins de succès. J'ai pas mal de questions de compréhension des signaux. Je dépile depuis 1 mois tout ce que je trouve sur le sujet, les repairlogs notamment ceux de Bouz, les vidéos youtube.

Ce soir, je suis devant un slot qui redémarre en boucle. ( Pin 19 et 20 du 68k qui font le yoyo).
Le bios est OK et quand j'observe les /WE des wrams, le signal reste à haut à la sonde logique.

Quand un cas comme ça se produit, ma logique (qui est sûrement fausse !) serait que le chip qui devrait basculer ça signal vers le bas ne le fait pas. Dans mon cas, c'est le neo-c1 via les signaux wwl et wwu dont les pins indiquent un signal haut permanent.
Pour autant, je vois 2 sources : soit le neo-c1 est HS, soit il y a autre chose en amont qui déconne mais je ne vois pas quoi ?

Une idée ?

Merci !


Dernière édition par Ragefan le Lun 4 Sep 2023 - 21:40, édité 1 fois
Ragefan
Ragefan
Loose
Loose

Messages : 135
Date d'inscription : 03/09/2023

Revenir en haut Aller en bas

[WIP] réparation MVS1 FZS #1 Empty Re: [WIP] réparation MVS1 FZS #1

Message par Bouz Lun 4 Sep 2023 - 13:40

Coucou!
J'espère que tu mèles à la fois les repair logs de Bouz et ses vidéos de réparation Wink.
Quand tu parles des broches 19 et 20, tu parles du 68000 PLCC, j'imagine?
Si tu veux faire le lien avec les broches /W des WRAMs, il faut regarder ce qui se passe au niveau de la broche 9 (RW) du CPU. C'est elle, via le memory mapping, va se traduire en /WE sur les WRAM.

Dans l'immédiat, concrètement, tu as un souci de RESET forcé, probablement par le watchdog. L'idée serait déjà e regarder la tête des signaux d'adresse et de données au niveau du CPU pour voir si tu n'as pas un composant HS (de la RAM, de la ROM, une puce NEO-quelquechose).
Si tu mets le son, tu entends un petit claquement répétitif ?
Bouz
Bouz
Scellé
Scellé

Messages : 3047
Date d'inscription : 11/06/2019
Age : 46
Localisation : Saint Bauzille de Putois

https://www.youtube.com/@AurelienBricole

Revenir en haut Aller en bas

[WIP] réparation MVS1 FZS #1 Empty Re: [WIP] réparation MVS1 FZS #1

Message par Ragefan Lun 4 Sep 2023 - 19:19

Merci bcp pour tes conseils ! Je vais te dire ça rapidement. J'ai pas mal de slots à réparer avec à chaque fois des cas différents. Je vais faire un topic pour chacun de façon à enrichir la base de connaissance du forum Smile
Ragefan
Ragefan
Loose
Loose

Messages : 135
Date d'inscription : 03/09/2023

Revenir en haut Aller en bas

[WIP] réparation MVS1 FZS #1 Empty Re: [WIP] réparation MVS1 FZS #1

Message par Bouz Lun 4 Sep 2023 - 19:24

Très bonne idée! Si je peux donner un coup de main...
Bouz
Bouz
Scellé
Scellé

Messages : 3047
Date d'inscription : 11/06/2019
Age : 46
Localisation : Saint Bauzille de Putois

https://www.youtube.com/@AurelienBricole

Revenir en haut Aller en bas

[WIP] réparation MVS1 FZS #1 Empty Re: [WIP] réparation MVS1 FZS #1

Message par Ragefan Lun 4 Sep 2023 - 19:31

Bouz a écrit:Très bonne idée! Si je peux donner un coup de main...

Avec plaisir ! ( et respect de ma part vu tout ce que j'ai à apprendre !)
Ragefan
Ragefan
Loose
Loose

Messages : 135
Date d'inscription : 03/09/2023

Revenir en haut Aller en bas

[WIP] réparation MVS1 FZS #1 Empty Re: [WIP] réparation MVS1 FZS #1

Message par cypher Lun 4 Sep 2023 - 21:44

Merci Ragefan pour enrichir le forum Wink

_________________
"amoureux des vieilles fentes" I love you

[WIP] réparation MVS1 FZS #1 943190OD9MGVj [WIP] réparation MVS1 FZS #1 514500kof94photo32 [WIP] réparation MVS1 FZS #1 Sign_a10
cypher
cypher
Scellé
Scellé

Messages : 4468
Date d'inscription : 25/10/2015
Age : 47
Localisation : 62

Revenir en haut Aller en bas

[WIP] réparation MVS1 FZS #1 Empty Re: [WIP] réparation MVS1 FZS #1

Message par Ragefan Lun 4 Sep 2023 - 21:57

Un petit update :
J'ai mis un unibios et lancé le slot.
J'ai effectivement un click rapide mais quand j'ai attendu le temps de faire les mesures, le click disparaît et l'écran reste noir.
Le constat est radical :
Je pensais que le pin 20 du 68k faisait le yoyo mais ça s'arrête, il est haut ou bas selon quand je redémarre le slot. Par contre, le pin 19 est tjs bas (cpu halté). J'ai pas l'impression que le cpu comprenne le reset qu'il reçoit ?
Plus étrange :
Au niveau du bios, je retrouve les haut et bas que je vois sur le bus de donnée du 68k mais sur le bus d'adresse j'ai A1 qui fait déconner ma sonde (elle fait un bruit genre pfiouuu), A3 qui sur lequel la sonde n'indique carrément rien ( ni haut ni bas) ainsi que sur A9 et A14 au moins.
Quand je regarde au cul du 68k, j'ai les même signaux sur le bus d'adresse en sortie du cpu.
Le Bios est OE high et CE Low
Les wrams sont WE High et OE High, et CS Low.
Ni le bios ni la wram n'est accédee ou alors je ne le vois pas car le cpu le reset pas ?
En regardant le signal reset provenant du neo-b1, ça semble correspondre à ce qui arrive au 68k : en gros halt bas et reset haut.

Verdict : je penche pour un 68k aux fraises ou un neo-b1 ?
Sans oscillo, pas facile de voir la tête des signaux.

Dernier point : j'ai 300 ohm entre les 2 plots 5v et gnd donc ça sents le composant en court circuit qqpart.
Ragefan
Ragefan
Loose
Loose

Messages : 135
Date d'inscription : 03/09/2023

Revenir en haut Aller en bas

[WIP] réparation MVS1 FZS #1 Empty Re: [WIP] réparation MVS1 FZS #1

Message par Bouz Mar 5 Sep 2023 - 13:35

Pour les 300 ohms, ça ne me choque pas particulièrement.
Quelque chose chauffe particulièrement (à part la puce Yamaha, qui chauffe à bloc tout le temps)?

Concernant les signaux, bizarre que le RESET soit fixe, ça voudrait dire que le watchdog ne fonctionne pas (et donc pas de clic clic clic audio).
Le HALT, il faut regarder du côté du Wiki NeoGeo dev, tu devrais trouver à quoi il est raccordé. Je pensais qu'il n'était pas utilisé, en l'occurrence.
Petit détail: le signal HALT sur le 68000 est à double sens. Il peut être utilisé par le CPU pour mettre des copro en veille, et par un coposant tiers pour mettre e CPU en veille. Il est notamment utilisé pour de la négociation de bus partagé. Essaie de suivre les lignes pour voir qui le pilote, et si la puce connectée dessus a des entrées intéressantes?
Bouz
Bouz
Scellé
Scellé

Messages : 3047
Date d'inscription : 11/06/2019
Age : 46
Localisation : Saint Bauzille de Putois

https://www.youtube.com/@AurelienBricole

Revenir en haut Aller en bas

[WIP] réparation MVS1 FZS #1 Empty Re: [WIP] réparation MVS1 FZS #1

Message par Ragefan Mar 5 Sep 2023 - 13:39

Je crois que le halt et le reset viennent du neo-b1.
Effectivement, le clic clic audio n'est pas très franc, c'est plus l'image qui saute au début puis d'arrête. Comme si le Watchdog ne fonctionnait plus au bout d'un certain temps.

Je vois le reset bagoter au début mais pas le halt, c'est bizarre.
Ragefan
Ragefan
Loose
Loose

Messages : 135
Date d'inscription : 03/09/2023

Revenir en haut Aller en bas

[WIP] réparation MVS1 FZS #1 Empty Re: [WIP] réparation MVS1 FZS #1

Message par theWave Mer 6 Sep 2023 - 22:30

Alors question de noob mais de ma petite expérience d'arcadien, quand ça reboote tout seul c'est souvent l'alim...

Tu as bien testé ton +5v et ton alim est assez costaud ?

_________________
Sanjuro a écrit:en Special Guest Star, WRC dans le rôle de theWave
ancien directeur du service de renseignements NGS, il a le bras long comme un anaconda sous stéroïdes, si un gros bonnet doit se coucher, c'est qu'il en a donné l'ordre.
theWave
theWave
Pièce unique
Pièce unique

Messages : 10125
Date d'inscription : 25/10/2015

Revenir en haut Aller en bas

[WIP] réparation MVS1 FZS #1 Empty Re: [WIP] réparation MVS1 FZS #1

Message par Ragefan Mer 6 Sep 2023 - 23:34

L'alim fonctionne avec d'autres slots. C'est un symptôme ici de click of death mais assez bizarre. J'ai bien 5v en entrée.
Ragefan
Ragefan
Loose
Loose

Messages : 135
Date d'inscription : 03/09/2023

Revenir en haut Aller en bas

[WIP] réparation MVS1 FZS #1 Empty Re: [WIP] réparation MVS1 FZS #1

Message par Ragefan Ven 13 Oct 2023 - 22:54

Bouz a écrit:Pour les 300 ohms, ça ne me choque pas particulièrement.
Quelque chose chauffe particulièrement (à part la puce Yamaha, qui chauffe à bloc tout le temps)?

Concernant les signaux, bizarre que le RESET soit fixe, ça voudrait dire que le watchdog ne fonctionne pas (et donc pas de clic clic clic audio).
Le HALT, il faut regarder du côté du Wiki NeoGeo dev, tu devrais trouver à quoi il est raccordé. Je pensais qu'il n'était pas utilisé, en l'occurrence.
Petit détail: le signal HALT sur le 68000 est à double sens. Il peut être utilisé par le CPU pour mettre des copro en veille, et par un coposant tiers pour mettre e CPU en veille. Il est notamment utilisé pour de la négociation de bus partagé. Essaie de suivre les lignes pour voir qui le pilote, et si la puce connectée dessus a des entrées intéressantes?

Après avoir regardé plus en détail, j'ai vraiment un comportement bizarre sur halt est bas mais le reset oscille très lentement (en gros 10 sec entre chaque) de haut à bas sans réellement déclenxher la Watchdog. Je pense vraiment pour un 68k cassé ?

PS : je n'ai rien à l'écran

Néo E0/F0/LSPC2 sont chaudes
Même sans bios, slot n'affiche pas grand chose et ne fait pas de click ( tjs des oscillations bizarres entre reset et halt)
Ragefan
Ragefan
Loose
Loose

Messages : 135
Date d'inscription : 03/09/2023

Revenir en haut Aller en bas

[WIP] réparation MVS1 FZS #1 Empty Re: [WIP] réparation MVS1 FZS #1

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum